VMWare Workstation 10 no funciona en Ubuntu 14.04 LTS

vmware_image

Hola amigos despues de instalar la version de Ubuntu 14.04 LTS e intentar abrir mi Workstation
me sale este mensaje: “Before you can run VMware, several modules must be compiled and loaded into the running kernel” o lo que es lo mismo que antes de arrancar el VMware algunos modulos
deben ser compilados en el kernel. Esto ocurre porque Ubuntu 14.04 está utilizando el 3,13 kernel y VMWare Estación de trabajo 10 no es tan amistosa con esta versión del kernel. Aquí encontre un script para solucionarlo.
Simplemente parchea el archivo filter.c en / usr / lib / vmware / modules / source / vmnet.tar. Guardad el script en un archivo y ejecutarlo como root.

#!/bin/bash

cat << EOF > /tmp/filter.c.patch
— vmnet-only/filter.c 2013-10-18 15:11:55.000000000 -0400
+++ vmnet-only/filter.c 2013-12-21 20:15:15.000000000 -0500
@@ -27,6 +27,7 @@
#include “compat_module.h”
#include #include +#include #if COMPAT_LINUX_VERSION_CHECK_LT(3, 2, 0)
# include #else
@@ -203,7 +204,11 @@
#endif

static unsigned int
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0) VNetFilterHookFn(unsigned int hooknum, // IN: +#else +VNetFilterHookFn(const struct nf_hook_ops *ops, // IN: +#endif #ifdef VMW_NFHOOK_USES_SKB struct sk_buff *skb, // IN: #else @@ -252,7 +257,12 @@ /* When the host transmits, hooknum is VMW_NF_INET_POST_ROUTING. */ /* When the host receives, hooknum is VMW_NF_INET_LOCAL_IN. */ - transmit = (hooknum == VMW_NF_INET_POST_ROUTING); + +#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0) + transmit = (hooknum == VMW_NF_INET_POST_ROUTING); +#else + transmit = (ops->hooknum == VMW_NF_INET_POST_ROUTING);
+#endif

packetHeader = compat_skb_network_header(skb);
ip = (struct iphdr*)packetHeader;
EOF

cd /usr/lib/vmware/modules/source
# untar the vmnet modules
tar -xvf vmnet.tar
#run a the patch you should have just saved earlier
patch vmnet-only/filter.c < /tmp/filter.c.patch # re-tar the modules tar -uvf vmnet.tar vmnet-only #delete the previous working directory rm -rf vmnet-only Una vez hecho esto ya podeis hacer funcionar vuestro Vmware WorkStation! Saludos!!. http://fazlearefin.blogspot.ca/2014/03/vmware-workstation-10-not-working-on.html

Post Tags
About Author: Gabriel Goncalves
Entusiasta de sistemas operativos, y soluciones en cloud Certificado en LPI, y Cloud por Rackspace.

Deja un comentario

Linkedin